blob: f3ab3da8d2a248e891f928d80be74d6470c7b269 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001From a188ea1ada6b990b72b91266ae02da058dcd9523 Mon Sep 17 00:00:00 2001
2From: Kurt Roeckx <kurt@roeckx.be>
3Date: Fri, 29 Jun 2018 15:49:32 +0800
4Subject: [PATCH] Make readelf -w output debug information on mips
5
6Bug-Debian: http://bugs.debian.org/662041
7Forwarded: not-needed
8
9Upstreams wants a change where this is handled by a hook that needs
10to be filled in by the backend for the arch.
11
12Signed-off-by: Kurt Roeckx <kurt@roeckx.be>
13
14Upstream-Status: Pending [from debian]
15mips_readelf_w.patch and rebase to 0.172
16
17http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.170-0.5.debian.tar.xz
18Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
19---
20 src/readelf.c | 3 ++-
21 1 file changed, 2 insertions(+), 1 deletion(-)
22
23diff --git a/src/readelf.c b/src/readelf.c
24index f185897..0db197c 100644
25--- a/src/readelf.c
26+++ b/src/readelf.c
27@@ -10979,7 +10979,8 @@ print_debug (Dwfl_Module *dwflmod, Ebl *ebl, GElf_Ehdr *ehdr)
28 GElf_Shdr shdr_mem;
29 GElf_Shdr *shdr = gelf_getshdr (scn, &shdr_mem);
30
31- if (shdr != NULL && shdr->sh_type == SHT_PROGBITS)
32+ if (shdr != NULL && (
33+ (shdr->sh_type == SHT_PROGBITS) || (shdr->sh_type == SHT_MIPS_DWARF)))
34 {
35 static const struct
36 {
37--
382.7.4
39