blob: f4c6f40fc5e3d58ca42b8a0c25a0055a8b4df768 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001From fe7613a3b9f2443cc11917826348d4521f267c96 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 29 Jun 2018 15:48:33 +0800
4Subject: [PATCH] testsuite ignore elflint
5
6On many architectures this test fails because binaries/libs produced by
7binutils don't pass elflint. However elfutils shouldn't FTBFS because of this.
8
9So we run the tests on all archs to see what breaks, but if it breaks we ignore
10the result (exitcode 77 means: this test was skipped).
11
12Upstream-Status: Pending [from debian]
13testsuite-ignore-elflint.diff and rebase to 0.172
14
15Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
16---
17 tests/run-elflint-self.sh | 2 +-
18 tests/test-subr.sh | 15 +++++++++++++++
19 2 files changed, 16 insertions(+), 1 deletion(-)
20
21diff --git a/tests/run-elflint-self.sh b/tests/run-elflint-self.sh
22index 58fa7d0..85d21a5 100755
23--- a/tests/run-elflint-self.sh
24+++ b/tests/run-elflint-self.sh
25@@ -18,5 +18,5 @@
26
27 . $srcdir/test-subr.sh
28
29-testrun_on_self ${abs_top_builddir}/src/elflint --quiet --gnu-ld
30+testrun_on_self_skip ${abs_top_builddir}/src/elflint --quiet --gnu-ld
31 testrun_on_self_compressed ${abs_top_builddir}/src/elflint --quiet --gnu-ld
32diff --git a/tests/test-subr.sh b/tests/test-subr.sh
33index 09f428d..26f61f1 100644
34--- a/tests/test-subr.sh
35+++ b/tests/test-subr.sh
36@@ -201,3 +201,18 @@ testrun_on_self_quiet()
37 # Only exit if something failed
38 if test $exit_status != 0; then exit $exit_status; fi
39 }
40+
41+# Same as testrun_on_self(), but skip on failure.
42+testrun_on_self_skip()
43+{
44+ exit_status=0
45+
46+ for file in $self_test_files; do
47+ testrun $* $file \
48+ || { echo "*** failure in $* $file"; exit_status=77; }
49+ done
50+
51+ # Only exit if something failed
52+ if test $exit_status != 0; then exit $exit_status; fi
53+}
54+
55--
562.7.4
57