Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "Vendor Package Management for Golang" |
| 2 | HOMEPAGE = "https://glide.sh" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=54905cf894f8cc416a92f4fc350c35b2" |
| 5 | |
| 6 | GO_IMPORT = "github.com/Masterminds/glide" |
| 7 | SRC_URI = "git://${GO_IMPORT}" |
| 8 | SRCREV = "9ef6ca313b3200079861f2de4e567b1d22081d19" |
| 9 | |
| 10 | inherit go |
| 11 | |
| 12 | RDEPENDS_${PN}-dev += "bash" |
| 13 | RDEPENDS_${PN}-ptest += "bash" |
| 14 | |
| 15 | BBCLASSEXTEND = "native nativesdk" |
| 16 | |
| 17 | # for x86 ends with textrel in ${PN} |
| 18 | # http://errors.yoctoproject.org/Errors/Details/185631/ |
| 19 | # ERROR: QA Issue: ELF binary '/work/i586-oe-linux/glide/0.13.1-r0/packages-split/glide/usr/bin/glide' has relocations in .text [textrel] |
| 20 | INSANE_SKIP_${PN} += "textrel" |
| 21 | |
| 22 | # for aarch64 ends with textrel in ${PN}-ptest |
| 23 | # http://errors.yoctoproject.org/Errors/Details/185633/ |
| 24 | # ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/glide.test' has relocations in .text |
| 25 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/dependency/dependency.test' has relocations in .text |
| 26 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/repo/repo.test' has relocations in .text |
| 27 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/mirrors/mirrors.test' has relocations in .text |
| 28 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/cfg/cfg.test' has relocations in .text |
| 29 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/godep/strip/strip.test' has relocations in .text |
| 30 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/path/path.test' has relocations in .text |
| 31 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/tree/tree.test' has relocations in .text |
| 32 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/util/util.test' has relocations in .text |
| 33 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/action/action.test' has relocations in .text |
| 34 | # ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/cache/cache.test' has relocations in .text [textrel] |
| 35 | INSANE_SKIP_${PN}-ptest += "textrel" |