blob: cfc2186b31cfac433f6cbb85bc5ff6c48dfeca68 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Dependency management tool for Golang"
2HOMEPAGE = "https://github.com/golang/dep"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d"
5
6GO_IMPORT = "github.com/golang/dep"
7SRC_URI = "git://${GO_IMPORT} \
8 file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \
9 "
10
11# Points to 0.5.0 tag
12SRCREV = "224a564abe296670b692fe08bb63a3e4c4ad7978"
13
14inherit go
15
16GO_INSTALL = "${GO_IMPORT}/cmd/dep"
17
18RDEPENDS_${PN}-dev += "bash"
19
20BBCLASSEXTEND = "native nativesdk"
21
22# for x86 ends with textrel in ${PN}
23# http://errors.yoctoproject.org/Errors/Details/185630/
24# ERROR: QA Issue: ELF binary '/work/i586-oe-linux/go-dep/0.4.1-r0/packages-split/go-dep/usr/bin/dep' has relocations in .text [textrel]
25INSANE_SKIP_${PN} += "textrel"
26
27# for aarch64 ends with textrel in ${PN}-ptest
28# http://errors.yoctoproject.org/Errors/Details/185632/
29# ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/go-dep/0.4.1-r0/packages-split/go-dep-ptest/usr/lib/go-dep/ptest/github.com/golang/dep/cmd/dep/dep.test' has relocations in .text [textrel]
30INSANE_SKIP_${PN}-ptest += "textrel"
31
32# For compiling ptest on mips and mips64, the current go-dep version fails with the go 1.11 toolchain.
33# error message: vet config not found
34PTEST_ENABLED_mips = "0"
35PTEST_ENABLED_mips64 = "0"