blob: 5b10e682978fe7a85f07de7ad1638b4a808d2f0e [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "C bindings for apps which will manipulate JSON data"
2DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
3HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6
7SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz"
8SRC_URI[md5sum] = "04969ad59cc37bddd83741a08b98f350"
9SRC_URI[sha256sum] = "b87e608d4d3f7bfdd36ef78d56d53c74e66ab278d318b71e6002a369d36f4873"
10
11UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+).tar"
12# json-c releases page is fetching the list of releases in some weird XML format
13# from https://s3.amazonaws.com/json-c_releases and processes it with javascript :-/
14#UPSTREAM_CHECK_URI = "https://s3.amazonaws.com/json-c_releases/releases/index.html"
15RECIPE_UPSTREAM_VERSION = "0.13.1"
16RECIPE_UPSTREAM_DATE = "Mar 04, 2018"
17CHECK_DATE = "May 02, 2018"
18
19RPROVIDES_${PN} = "libjson"
20
21inherit autotools
22
23EXTRA_OECONF = "--enable-rdrand"
24
25do_configure_prepend() {
26 # Clean up autoconf cruft that should not be in the tarball
27 rm -f ${S}/config.status
28}
29
30BBCLASSEXTEND = "native nativesdk"