blob: 8fa0978d43a01afea6fb0691c7cb4ef85a59958c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001require bash.inc
2
3# GPLv2+ (< 4.0), GPLv3+ (>= 4.0)
4LICENSE = "GPLv3+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7SRC_URI = "${GNU_MIRROR}/bash/${BP}.tar.gz;name=tarball \
8 ${GNU_MIRROR}/bash/bash-4.4-patches/bash44-019;apply=yes;striplevel=0;name=patch019 \
9 ${GNU_MIRROR}/bash/bash-4.4-patches/bash44-020;apply=yes;striplevel=0;name=patch020 \
10 ${GNU_MIRROR}/bash/bash-4.4-patches/bash44-021;apply=yes;striplevel=0;name=patch021 \
11 ${GNU_MIRROR}/bash/bash-4.4-patches/bash44-022;apply=yes;striplevel=0;name=patch022 \
12 ${GNU_MIRROR}/bash/bash-4.4-patches/bash44-023;apply=yes;striplevel=0;name=patch023 \
13 file://execute_cmd.patch;striplevel=0 \
14 file://mkbuiltins_have_stringize.patch \
15 file://build-tests.patch \
16 file://test-output.patch \
17 file://fix-run-coproc-run-heredoc-run-execscript-run-test-f.patch \
18 file://run-ptest \
19 file://fix-run-builtins.patch \
20 file://0001-help-fix-printf-format-security-warning.patch \
21 file://pathexp-dep.patch \
22 "
23
24SRC_URI[tarball.md5sum] = "518e2c187cc11a17040f0915dddce54e"
25SRC_URI[tarball.sha256sum] = "604d9eec5e4ed5fd2180ee44dd756ddca92e0b6aa4217bbab2b6227380317f23"
26
27SRC_URI[patch019.md5sum] = "8f43e1d277b02f3319a34c1cd4a4ff3e"
28SRC_URI[patch019.sha256sum] = "27170d6edfe8819835407fdc08b401d2e161b1400fe9d0c5317a51104c89c11e"
29SRC_URI[patch020.md5sum] = "5217ff08c444446ec306dce60437c288"
30SRC_URI[patch020.sha256sum] = "1840e2cbf26ba822913662f74037594ed562361485390c52813b38156c99522c"
31SRC_URI[patch021.md5sum] = "282c7d9b38da8005d25b4f816328a2f4"
32SRC_URI[patch021.sha256sum] = "bd8f59054a763ec1c64179ad5cb607f558708a317c2bdb22b814e3da456374c1"
33SRC_URI[patch022.md5sum] = "0b709c9d7f8e6cf267a8b863efb899f7"
34SRC_URI[patch022.sha256sum] = "45331f0936e36ab91bfe44b936e33ed8a1b1848fa896e8a1d0f2ef74f297cb79"
35SRC_URI[patch023.md5sum] = "fe2e0ca4cf9409ff0e9428e1236f983e"
36SRC_URI[patch023.sha256sum] = "4fec236f3fbd3d0c47b893fdfa9122142a474f6ef66c20ffb6c0f4864dd591b6"
37
38DEBUG_OPTIMIZATION_append_armv4 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}"
39DEBUG_OPTIMIZATION_append_armv5 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}"
40
41BBCLASSEXTEND = "nativesdk"