blob: 19f6586526bf1251cc97d49767a294d905749059 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001require gzip.inc
2
3LICENSE = "GPLv3+"
4
5SRC_URI = "${GNU_MIRROR}/gzip/${BP}.tar.gz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006 file://run-ptest \
7 file://gnulib.patch \
8 "
Brad Bishop316dfdd2018-06-25 12:45:53 -04009SRC_URI_append_class-target = " file://wrong-path-fix.patch"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
12 file://gzip.h;beginline=8;endline=20;md5=6e47caaa630e0c8bf9f1bc8d94a8ed0e"
13
14PROVIDES_append_class-native = " gzip-replacement-native"
15
16BBCLASSEXTEND = "native"
17
18inherit ptest
19
20do_install_ptest() {
21 mkdir -p ${D}${PTEST_PATH}/src/build-aux
22 cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/src/build-aux/
23 mkdir -p ${D}${PTEST_PATH}/src/tests
24 cp -r ${S}/tests/* ${D}${PTEST_PATH}/src/tests
25 sed -e 's/^abs_srcdir = ..*/abs_srcdir = \.\./' \
26 -e 's/^top_srcdir = ..*/top_srcdir = \.\./' \
27 -e 's/^GREP = ..*/GREP = grep/' \
28 -e 's/^AWK = ..*/AWK = awk/' \
29 -e 's/^srcdir = ..*/srcdir = \./' \
30 -e 's/^Makefile: ..*/Makefile: /' \
31 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
32 -e 's|${DEBUG_PREFIX_MAP}||g' \
33 -e 's:${HOSTTOOLS_DIR}/::g' \
34 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
35 ${B}/tests/Makefile > ${D}${PTEST_PATH}/src/tests/Makefile
36}
37
38SRC_URI[md5sum] = "929d6a6b832f75b28e3eeeafb30c1d9b"
39SRC_URI[sha256sum] = "5d2d3a3432ef32f24cdb060d278834507b481a75adeca18850c73592f778f6ad"
40