blob: 47447acd6cb7af7d767a90778907dab631c0871f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "NSS module for glibc, to provide NIS support for glibc"
5
6DESCRIPTION = "This package contains the NSS NIS plugin for glibc.\
7This code was formerly part of glibc, but is now standalone to\
8be able to link against TI-RPC for IPv6 support."
9
10HOMEPAGE = "https://github.com/thkukuk/libnss_nis"
11LICENSE = "LGPL-2.1"
12LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
13SECTION = "libs"
14DEPENDS += "libtirpc libnsl2"
15
16PV = "3.0+git${SRCPV}"
17
18SRCREV = "d4aea48657a8e90d7922574b8021ee03915a36cb"
19
20SRC_URI = "git://github.com/thkukuk/libnss_nis \
21 "
22
23S = "${WORKDIR}/git"
24
25inherit autotools pkgconfig
26
27BBCLASSEXTEND += "native nativesdk"
28#
29# We will skip parsing this packagegeoup for non-glibc systems
30#
31COMPATIBLE_HOST_libc-musl = 'null'