blob: c6a4500b8e8ae2cc482689c074df1330a56edf7c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Midnight Commander is an ncurses based file manager"
2HOMEPAGE = "http://www.midnight-commander.org/"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2"
5SECTION = "console/utils"
6DEPENDS = "ncurses glib-2.0 util-linux"
7RDEPENDS_${PN} = "ncurses-terminfo"
8
9SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2 \
10 file://0001-mc-replace-perl-w-with-use-warnings.patch \
11 "
12SRC_URI[md5sum] = "63d2b90e2198ee79d08eb4a8989220e2"
13SRC_URI[sha256sum] = "251d9f0ef9309ef3eea0fdc4c12b8b61149e5056bef1b2de2ccc7f015d973444"
14
15inherit autotools gettext pkgconfig
16
17#
18# Both Samba (smb) and sftp require package delivered from meta-openembedded
19#
20PACKAGECONFIG ??= ""
21PACKAGECONFIG[smb] = "--enable-vfs-smb,--disable-vfs-smb,samba,"
22PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
23
24EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x"
25
26CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
27
28do_install_append () {
29 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
30
31 rm ${D}${libexecdir}/mc/extfs.d/s3+ ${D}${libexecdir}/mc/extfs.d/uc1541
32}
33
34PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers ${BPN}-fish"
35
36SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
37FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
38 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
39 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
40 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
41 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
42 ${libexecdir}/mc/extfs.d/uzip"
43RDEPENDS_${BPN}-helpers-perl = "perl"
44
45SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts"
46FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
47
48SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts"
49FILES_${BPN}-fish = "${libexecdir}/mc/fish"