blob: 2c4d88a9e7a5e8b4f082166b5bb159de99d48641 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Tool for managing software RAID under Linux"
2HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
3
4# Some files are GPLv2+ while others are GPLv2.
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
8 file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
9
10
11SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \
12 file://gcc-4.9.patch \
13 file://mdadm-3.3.2_x32_abi_time_t.patch \
14 file://mdadm-fix-ptest-build-errors.patch \
15 file://0001-Fix-the-path-of-corosync-and-dlm-header-files-check.patch \
16 file://run-ptest \
17 file://0001-mdadm.h-Undefine-dprintf-before-redefining.patch \
18 file://0001-include-sys-sysmacros.h-for-major-minor-defintions.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019 file://0001-mdadm-Add-Wimplicit-fallthrough-0-in-Makefile.patch \
20 file://0002-mdadm-Specify-enough-length-when-write-to-buffer.patch \
21 file://0003-Replace-snprintf-with-strncpy-at-some-places-to-avoi.patch \
22 file://0004-mdadm-Forced-type-conversion-to-avoid-truncation.patch \
23 file://0005-Add-a-comment-to-indicate-valid-fallthrough.patch \
24 file://0001-Use-CC-to-check-for-implicit-fallthrough-warning-sup.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025 file://0001-use-memmove-instead-of-memcpy-on-overlapping-region.patch \
26 file://0001-Disable-gcc8-warnings.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027 "
28SRC_URI[md5sum] = "2cb4feffea9167ba71b5f346a0c0a40d"
29SRC_URI[sha256sum] = "1d6ae7f24ced3a0fa7b5613b32f4a589bb4881e3946a5a2c3724056254ada3a9"
30
31CFLAGS += "-fno-strict-aliasing"
32inherit autotools-brokensep
33
34EXTRA_OEMAKE = 'CHECK_RUN_DIR=0 CXFLAGS="${CFLAGS}"'
35# PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h
36# prevents 64-bit userland from seeing this definition, instead defaulting
37# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
38# int-ll64.h included
39CFLAGS_append_powerpc64 = ' -D__SANE_USERSPACE_TYPES__'
40CFLAGS_append_mipsarchn64 = ' -D__SANE_USERSPACE_TYPES__'
41CFLAGS_append_mipsarchn32 = ' -D__SANE_USERSPACE_TYPES__'
42
43do_compile() {
44 # Point to right sbindir
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080045 sed -i -e "s;BINDIR = /sbin;BINDIR = $base_sbindir;" -e "s;UDEVDIR = /lib;UDEVDIR = $nonarch_base_libdir;" ${S}/Makefile
Brad Bishop6e60e8b2018-02-01 10:27:11 -050046 oe_runmake SYSROOT="${STAGING_DIR_TARGET}"
47}
48
49do_install() {
50 export STRIP=""
51 autotools_do_install
52}
53
54inherit ptest
55
56do_compile_ptest() {
57 oe_runmake test
58}
59
60do_install_ptest() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050061 cp -R --no-dereference --preserve=mode,links -v ${S}/tests ${D}${PTEST_PATH}/tests
Brad Bishop6e60e8b2018-02-01 10:27:11 -050062 cp ${S}/test ${D}${PTEST_PATH}
63 sed -e 's!sleep 0.*!sleep 1!g; s!/var/tmp!/!g' -i ${D}${PTEST_PATH}/test
64 ln -s ${base_sbindir}/mdadm ${D}${PTEST_PATH}/mdadm
65 for prg in test_stripe swap_super raid6check
66 do
67 install -D -m 755 $prg ${D}${PTEST_PATH}/
68 done
69}
70RDEPENDS_${PN}-ptest += "bash"
71RRECOMMENDS_${PN}-ptest += " \
72 coreutils \
73 util-linux \
74 kernel-module-loop \
75 kernel-module-linear \
76 kernel-module-raid0 \
77 kernel-module-raid1 \
78 kernel-module-raid10 \
79 kernel-module-raid456 \
80"