blob: ffa8388777912a56682becec5127d4858d314797 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2010 Intel Corporation
3#
4
5SUMMARY = "Standard full-featured Linux system"
6DESCRIPTION = "Package group bringing in packages needed for a more traditional full-featured Linux system"
7PR = "r6"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
9inherit packagegroup
10
11PACKAGES = "\
12 packagegroup-core-full-cmdline \
13 packagegroup-core-full-cmdline-libs \
14 packagegroup-core-full-cmdline-utils \
15 packagegroup-core-full-cmdline-extended \
16 packagegroup-core-full-cmdline-dev-utils \
17 packagegroup-core-full-cmdline-multiuser \
18 packagegroup-core-full-cmdline-initscripts \
19 packagegroup-core-full-cmdline-sys-services \
20 "
21
22python __anonymous () {
23 # For backwards compatibility after rename
24 namemap = {}
25 namemap["packagegroup-core-full-cmdline"] = "packagegroup-core-basic"
26 namemap["packagegroup-core-full-cmdline-libs"] = "packagegroup-core-basic-libs"
27 namemap["packagegroup-core-full-cmdline-utils"] = "packagegroup-core-basic-utils"
28 namemap["packagegroup-core-full-cmdline-extended"] = "packagegroup-core-basic-extended"
29 namemap["packagegroup-core-full-cmdline-dev-utils"] = "packagegroup-core-dev-utils"
30 namemap["packagegroup-core-full-cmdline-multiuser"] = "packagegroup-core-multiuser"
31 namemap["packagegroup-core-full-cmdline-initscripts"] = "packagegroup-core-initscripts"
32 namemap["packagegroup-core-full-cmdline-sys-services"] = "packagegroup-core-sys-services"
33
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034 packages = d.getVar("PACKAGES").split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -050035 for pkg in packages:
36 if pkg.endswith('-dev'):
37 mapped = namemap.get(pkg[:-4], None)
38 if mapped:
39 mapped += '-dev'
40 elif pkg.endswith('-dbg'):
41 mapped = namemap.get(pkg[:-4], None)
42 if mapped:
43 mapped += '-dbg'
44 else:
45 mapped = namemap.get(pkg, None)
46
47 if mapped:
48 oldtaskname = mapped.replace("packagegroup-core", "task-core")
49 mapstr = " %s %s" % (mapped, oldtaskname)
50 d.appendVar("RPROVIDES_%s" % pkg, mapstr)
51 d.appendVar("RREPLACES_%s" % pkg, mapstr)
52 d.appendVar("RCONFLICTS_%s" % pkg, mapstr)
53}
54
55
56RDEPENDS_packagegroup-core-full-cmdline = "\
57 packagegroup-core-full-cmdline-libs \
58 packagegroup-core-full-cmdline-utils \
59 packagegroup-core-full-cmdline-extended \
60 packagegroup-core-full-cmdline-dev-utils \
61 packagegroup-core-full-cmdline-multiuser \
62 packagegroup-core-full-cmdline-initscripts \
63 packagegroup-core-full-cmdline-sys-services \
64 "
65
66RDEPENDS_packagegroup-core-full-cmdline-libs = "\
67 glib-2.0 \
68 "
69
70RDEPENDS_packagegroup-core-full-cmdline-utils = "\
71 bash \
72 acl \
73 attr \
74 bc \
75 coreutils \
76 cpio \
77 e2fsprogs \
78 ed \
79 file \
80 findutils \
81 gawk \
82 gmp \
83 grep \
84 makedevs \
85 mc \
86 mc-fish \
87 mc-helpers \
88 mc-helpers-perl \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050089 ncurses \
90 net-tools \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050091 procps \
92 psmisc \
93 sed \
94 tar \
95 time \
96 util-linux \
97 zlib \
98 "
99
100RDEPENDS_packagegroup-core-full-cmdline-extended = "\
101 iproute2 \
102 iputils \
103 iptables \
104 module-init-tools \
105 openssl \
106 "
107
108RDEPENDS_packagegroup-core-full-cmdline-dev-utils = "\
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500109 diffutils \
110 m4 \
111 make \
112 patch \
113 "
114
115VIRTUAL-RUNTIME_initscripts ?= "initscripts"
116VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
117VIRTUAL-RUNTIME_login_manager ?= "busybox"
118VIRTUAL-RUNTIME_syslog ?= "sysklogd"
119RDEPENDS_packagegroup-core-full-cmdline-initscripts = "\
120 ${VIRTUAL-RUNTIME_initscripts} \
121 ${VIRTUAL-RUNTIME_init_manager} \
122 ethtool \
123 ${VIRTUAL-RUNTIME_login_manager} \
124 ${VIRTUAL-RUNTIME_syslog} \
125 "
126
127RDEPENDS_packagegroup-core-full-cmdline-multiuser = "\
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800128 bzip2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500129 cracklib \
130 gzip \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500131 shadow \
132 sudo \
133 "
134
135RDEPENDS_packagegroup-core-full-cmdline-sys-services = "\
136 at \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500137 cronie \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500138 logrotate \
139 nfs-utils \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500140 rpcbind \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500141 "