blob: cb5b288c484bada0ff7b9c18feb17261e6a18406 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001# Copyright (C) 2018 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "rpcsvc protocol definitions from glibc"
5
6DESCRIPTION = "This package contains rpcsvc proto.x files from glibc, which are\
7missing in libtirpc. Additional it contains rpcgen, which is needed\
8to create header files and sources from protocol files.\
9This package is only needed, if glibc is installed without the\
10deprecated sunrpc functionality and libtirpc should replace it."
11
12HOMEPAGE = "https://github.com/thkukuk/rpcsvc-proto"
13LICENSE = "BSD-3-Clause"
14LIC_FILES_CHKSUM = "file://COPYING;md5=0daaf958d5531ab86169ec6e275e1517"
15SECTION = "libs"
16DEPENDS += "rpcsvc-proto-native"
17
18PV = "1.4+git${SRCPV}"
19
20SRCREV = "9bc3b5b785723cfff459b0c01b39d87d4bed975c"
21
22SRC_URI = "git://github.com/thkukuk/${BPN} \
23 file://0001-Use-cross-compiled-rpcgen.patch \
24 "
25
26S = "${WORKDIR}/git"
27
28inherit autotools
29
30EXTRA_OEMAKE_class-native = " -C rpcgen"
31
32do_install_append() {
33 # They come from quota recipe
34 rm -rf ${D}${includedir}/rpcsvc/rquota.[hx]
35}
36
37BBCLASSEXTEND += "native nativesdk"