blob: 375dce949d036ac82ed9dad4e8d384aacfe99587 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Multiplexing terminal manager"
2DESCRIPTION = "Screen is a full-screen window manager \
3that multiplexes a physical terminal between several \
4processes, typically interactive shells."
5HOMEPAGE = "http://www.gnu.org/software/screen/"
6BUGTRACKER = "https://savannah.gnu.org/bugs/?func=additem&group=screen"
7
8SECTION = "console/utils"
9
10LICENSE = "GPLv3+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
12 file://screen.h;endline=26;md5=3971142989289a8198a544220703c2bf"
13
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014DEPENDS = "ncurses virtual/crypt \
Brad Bishop316dfdd2018-06-25 12:45:53 -040015 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
16RDEPENDS_${PN} = "base-files"
17
18SRC_URI = "${GNU_MIRROR}/screen/screen-${PV}.tar.gz \
19 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'file://screen.pam', '', d)} \
20 file://Remove-redundant-compiler-sanity-checks.patch \
21 file://Provide-cross-compile-alternatives-for-AC_TRY_RUN.patch \
22 file://Skip-host-file-system-checks-when-cross-compiling.patch \
23 file://Avoid-mis-identifying-systems-as-SVR4.patch \
24 file://0002-comm.h-now-depends-on-term.h.patch \
25 file://0001-fix-for-multijob-build.patch \
26 file://0001-configure.ac-fix-configure-failed-while-build-dir-ha.patch \
27 "
28
29SRC_URI[md5sum] = "a0f529d3333b128dfaa324d978ba73a8"
30SRC_URI[sha256sum] = "1b6922520e6a0ce5e28768d620b0f640a6631397f95ccb043b70b91bb503fa3a"
31
32inherit autotools texinfo
33
34PACKAGECONFIG ??= ""
35PACKAGECONFIG[utempter] = "ac_cv_header_utempter_h=yes,ac_cv_header_utempter_h=no,libutempter,"
36
37EXTRA_OECONF = "--with-pty-mode=0620 --with-pty-group=5 \
38 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)}"
39
40do_install_append () {
41 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then
42 install -D -m 644 ${WORKDIR}/screen.pam ${D}/${sysconfdir}/pam.d/screen
43 fi
44}
45
46pkg_postinst_${PN} () {
47 grep -q "^${bindir}/screen$" $D${sysconfdir}/shells || echo ${bindir}/screen >> $D${sysconfdir}/shells
48}
49
50pkg_postrm_${PN} () {
51 printf "$(grep -v "^${bindir}/screen$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells
52}