blob: 518c71feb17d4a3b582971993ae5ee0d9f6560a4 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "libsecret is a library for storing and retrieving passwords and other secrets"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6"
4
5inherit gnomebase gtk-doc vala gobject-introspection manpages
6
7DEPENDS += "glib-2.0 libgcrypt gettext-native intltool-native"
8
9PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"
10
11SRC_URI[archive.md5sum] = "c6cf132a56bd346fbf49a43abb02e5c2"
12SRC_URI[archive.sha256sum] = "5efbc890ba41a323ffe0599cd260fd12bd8eb62a04aa1bd1b2762575d253d66f"
13
14# http://errors.yoctoproject.org/Errors/Details/20228/
15ARM_INSTRUCTION_SET_armv4 = "arm"
16ARM_INSTRUCTION_SET_armv5 = "arm"
17ARM_INSTRUCTION_SET_armv6 = "arm"
18
19# vapigen.m4 bundled with the tarball does not yet have our cross-compilation fixes
20do_configure_prepend() {
21 rm -f ${S}/build/m4/vapigen.m4
22}