blob: 18b947948a38d71e0b4d7e9703e173a54dd5a1b5 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "The Cairo 2D vector graphics library"
2DESCRIPTION = "Cairo is a multi-platform library providing anti-aliased \
3vector-based rendering for multiple target backends. Paths consist \
4of line segments and cubic splines and can be rendered at any width \
5with various join and cap styles. All colors may be specified with \
6optional translucence (opacity/alpha) and combined using the \
7extended Porter/Duff compositing algebra as found in the X Render \
8Extension."
9HOMEPAGE = "http://cairographics.org"
10BUGTRACKER = "http://bugs.freedesktop.org"
11SECTION = "libs"
12
13LICENSE = "MPL-1 & LGPLv2.1 & GPLv3+"
14LICENSE_${PN} = "MPL-1 & LGPLv2.1"
15LICENSE_${PN}-dev = "MPL-1 & LGPLv2.1"
16LICENSE_${PN}-doc = "MPL-1 & LGPLv2.1"
17LICENSE_${PN}-gobject = "MPL-1 & LGPLv2.1"
18LICENSE_${PN}-script-interpreter = "MPL-1 & LGPLv2.1"
19LICENSE_${PN}-perf-utils = "GPLv3+"
Brad Bishop316dfdd2018-06-25 12:45:53 -040020
21LIC_FILES_CHKSUM = "file://COPYING;md5=e73e999e0c72b5ac9012424fa157ad77"
22
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023DEPENDS = "fontconfig glib-2.0 libpng pixman zlib"
24
Brad Bishop316dfdd2018-06-25 12:45:53 -040025SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.xz \
26 file://cairo-get_bitmap_surface-bsc1036789-CVE-2017-7475.diff \
27 file://0001-cairo-Fix-CVE-2017-9814.patch \
28 "
29
30SRC_URI[md5sum] = "9f0db9dbfca0966be8acd682e636d165"
31SRC_URI[sha256sum] = "8c90f00c500b2299c0a323dd9beead2a00353752b2092ead558139bd67f7bf16"
32
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033inherit autotools pkgconfig upstream-version-is-even gtk-doc multilib_script
Brad Bishop316dfdd2018-06-25 12:45:53 -040034
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035MULTILIB_SCRIPTS = "${PN}-perf-utils:${bindir}/cairo-trace"
36
37X11DEPENDS = "virtual/libx11 libsm libxrender libxext"
38
39PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'directfb', d)} \
40 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 xcb', '', d)} \
41 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'opengl', '', d)}"
42
43PACKAGECONFIG[x11] = "--with-x=yes -enable-xlib,--with-x=no --disable-xlib,${X11DEPENDS}"
44PACKAGECONFIG[xcb] = "--enable-xcb,--disable-xcb,libxcb"
45PACKAGECONFIG[directfb] = "--enable-directfb=yes,,directfb"
46PACKAGECONFIG[valgrind] = "--enable-valgrind=yes,--disable-valgrind,valgrind"
47PACKAGECONFIG[egl] = "--enable-egl=yes,--disable-egl,virtual/egl"
48PACKAGECONFIG[glesv2] = "--enable-glesv2,--disable-glesv2,virtual/libgles2"
49PACKAGECONFIG[opengl] = "--enable-gl,--disable-gl,virtual/libgl"
50
51EXTRA_OECONF += " \
52 ${@bb.utils.contains('TARGET_FPU', 'soft', '--disable-some-floating-point', '', d)} \
53 --enable-tee \
54"
55
56# We don't depend on binutils so we need to disable this
57export ac_cv_lib_bfd_bfd_openr="no"
58# Ensure we don't depend on LZO
59export ac_cv_lib_lzo2_lzo2a_decompress="no"
60
61do_install_append () {
62 rm -rf ${D}${bindir}/cairo-sphinx
63 rm -rf ${D}${libdir}/cairo/cairo-fdr*
64 rm -rf ${D}${libdir}/cairo/cairo-sphinx*
65 rm -rf ${D}${libdir}/cairo/.debug/cairo-fdr*
66 rm -rf ${D}${libdir}/cairo/.debug/cairo-sphinx*
67}
68
69PACKAGES =+ "cairo-gobject cairo-script-interpreter cairo-perf-utils"
Brad Bishop316dfdd2018-06-25 12:45:53 -040070
71SUMMARY_cairo-gobject = "The Cairo library GObject wrapper library"
72DESCRIPTION_cairo-gobject = "A GObject wrapper library for the Cairo API."
73
74SUMMARY_cairo-script-interpreter = "The Cairo library script interpreter"
75DESCRIPTION_cairo-script-interpreter = "The Cairo script interpreter implements \
76CairoScript. CairoScript is used by tracing utilities to enable the ability \
77to replay rendering."
78
79DESCRIPTION_cairo-perf-utils = "The Cairo library performance utilities"
80
81FILES_${PN} = "${libdir}/libcairo.so.*"
Brad Bishop316dfdd2018-06-25 12:45:53 -040082FILES_${PN}-gobject = "${libdir}/libcairo-gobject.so.*"
83FILES_${PN}-script-interpreter = "${libdir}/libcairo-script-interpreter.so.*"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080084FILES_${PN}-perf-utils = "${bindir}/cairo-trace* ${libdir}/cairo/*.la ${libdir}/cairo/libcairo-trace.so.*"
85FILES_${PN}-dev += "${libdir}/cairo/*.so"
Brad Bishop316dfdd2018-06-25 12:45:53 -040086
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080087BBCLASSEXTEND = "native"