blob: 86d6a6bf3a7fc5460df92f47db09c6541d11b845 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001require ${BPN}.inc
2
3SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
4 file://0001-Simplify-wayland-scanner-lookup.patch \
5 file://0002-winsys-svga-drm-Include-sys-types.h.patch \
6 file://0003-Properly-get-LLVM-version-when-using-LLVM-Git-releas.patch \
7 file://0004-Use-Python-3-to-execute-the-scripts.patch \
8 file://0005-dri-i965-Add-missing-time.h-include.patch \
9 file://0006-use-PKG_CHECK_VAR-for-defining-WAYLAND_PROTOCOLS_DAT.patch \
10"
11
12SRC_URI[md5sum] = "2f8d2098ab478bc3907e42130577b54a"
13SRC_URI[sha256sum] = "55f5778d58a710a63d6635f000535768faf7db9e8144dc0f4fd1989f936c1a83"
14
15#because we cannot rely on the fact that all apps will use pkgconfig,
16#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
17do_install_append() {
18 if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
19 sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
20 fi
21}