blob: 22fe3af15d742879ec2c2db3c273b5c7336f070e [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection
15
16SRC_URI += "file://run-ptest \
17 file://0001-Enforce-recreation-of-docs-pango.types-it-is-build-c.patch \
18"
19SRC_URI[archive.md5sum] = "deb171a31a3ad76342d5195a1b5bbc7c"
20SRC_URI[archive.sha256sum] = "1d2b74cd63e8bd41961f2f8d952355aa0f9be6002b52c8aa7699d9f5da597c9d"
21
22DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
23
24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
25PACKAGECONFIG[x11] = "--with-xft,--without-xft,virtual/libx11 libxft"
26
27LEAD_SONAME = "libpango-1.0*"
28LIBV = "1.8.0"
29
30# This binary needs to be compiled for the host architecture. This isn't pretty!
31do_compile_prepend_class-target () {
32 if ${@bb.utils.contains('PTEST_ENABLED', '1', 'true', 'false', d)}; then
33 make CC="${BUILD_CC}" CFLAGS="" LDFLAGS="${BUILD_LDFLAGS}" AM_CPPFLAGS="$(pkg-config-native --cflags glib-2.0)" gen_all_unicode_LDADD="$(pkg-config-native --libs glib-2.0)" -C ${B}/tests gen-all-unicode
34 fi
35}
36
37FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
38FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la"
39
40RDEPENDS_${PN}-ptest += "liberation-fonts cantarell-fonts"
41
42RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \
43 pango-module-basic-fc pango-module-arabic-lang"
44
45BBCLASSEXTEND = "native"