blob: 112ee1a25e312c8855f140909317744604abe14a [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11 file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
13DEPENDS = "expat libxml2 libffi wayland-native"
14
15SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
16 file://fixpathinpcfiles.patch \
17 "
18SRC_URI[md5sum] = "0c215e53de71d6fb26f7102cdc6432d3"
19SRC_URI[sha256sum] = "4e72c2b56109ccfb6610d776e465f4ca0af2280c9c2f7d5cc23f0ed2548752f5"
20
21UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
22
23inherit autotools pkgconfig
24
25EXTRA_OECONF = "--disable-documentation --with-host-scanner"
26EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
27
28# Wayland installs a M4 macro for other projects to use, which uses the target
29# pkg-config to find files. Replace pkg-config with pkg-config-native.
30do_install_append_class-native() {
31 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
32 -e 's,$PKG_CONFIG,pkg-config-native,g' \
33 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
34}
35
36sysroot_stage_all_append_class-target () {
37 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
38 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
39}
40
41FILES_${PN} = "${libdir}/*${SOLIBS}"
42FILES_${PN}-dev += "${bindir} ${datadir}/wayland"
43
44BBCLASSEXTEND = "native nativesdk"