blob: fdc693be1424ea350d932378dd32d40a47b02f41 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "SM: Session Management library"
2
3DESCRIPTION = "The Session Management Library (SMlib) is a low-level \"C\" \
4language interface to XSMP. The purpose of the X Session Management \
5Protocol (XSMP) is to provide a uniform mechanism for users to save and \
6restore their sessions. A session is a group of clients, each of which \
7has a particular state."
8
9require xorg-lib-common.inc
10
11LICENSE = "MIT-style"
12LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb37f44e02bdbde80546024400728d"
13
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014DEPENDS += "libice xorgproto xtrans"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015
16# libSM can work without libuuid, we explicitly disable it to break the following circular dependency
17# when DISTRO_FEATURES contains 'systemd' and 'x11'.
18# systemd -> dbus -> libsm -> util-linux -> systemd
19EXTRA_OECONF += "--without-libuuid"
20
21PE = "1"
22
23XORG_PN = "libSM"
24
25BBCLASSEXTEND = "native"
26
27SRC_URI[md5sum] = "499a7773c65aba513609fe651853c5f3"
28SRC_URI[sha256sum] = "0baca8c9f5d934450a70896c4ad38d06475521255ca63b717a6510fdb6e287bd"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060029
Brad Bishop6e60e8b2018-02-01 10:27:11 -050030PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060031PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"