blob: 6766e252ef18fd2502abaa0adff1d8fcf7eb6350 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A library on top of GStreamer for building an RTSP server"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-rtsp-server/"
3SECTION = "multimedia"
4LICENSE = "LGPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d"
6
7DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base"
8
9PNREAL = "gst-rtsp-server"
10
11SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz \
12 file://0001-Don-t-hardcode-libtool-name-when-using-introspection.patch \
13 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
14 file://gtk-doc-tweaks.patch \
15 "
16
17SRC_URI[md5sum] = "c26b59dd2ea8b1a4a25e9f7e0f57a50e"
18SRC_URI[sha256sum] = "f7387755cf6ac5f334d4610f1f5aa7da4ff396a487dd5b789bb707f160222c98"
19
20S = "${WORKDIR}/${PNREAL}-${PV}"
21
22inherit autotools pkgconfig upstream-version-is-even gobject-introspection gtk-doc
23
24EXTRA_OECONF = "--disable-examples --disable-tests"
25
26# Starting with 1.8.0 gst-rtsp-server includes dependency-less plugins as well
27LIBV = "1.0"
28require gst-plugins-package.inc
29
30delete_pkg_m4_file() {
31 # This m4 file is out of date and is missing PKG_CONFIG_SYSROOT_PATH tweaks which we need for introspection
32 rm "${S}/common/m4/pkg.m4" || true
33}
34
35do_configure[prefuncs] += " delete_pkg_m4_file"