blob: 56327a632b4006aab42bd278bb3daa6ad54dbed3 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
Brad Bishop6f8dcde2018-10-16 10:47:12 +08006LIC_FILES_CHKSUM = "file://COPYING;md5=ef889a37a5a874490ac7ce116396f29a"
Brad Bishop316dfdd2018-06-25 12:45:53 -04007
8SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
9 file://0001-replace-krb5-config-with-pkg-config.patch \
Brad Bishop6f8dcde2018-10-16 10:47:12 +080010 file://CVE-2018-14618.patch \
Brad Bishopc4ea0752018-11-15 14:30:15 -080011 file://CVE-2018-16839.patch \
12 file://CVE-2018-16840.patch \
13 file://CVE-2018-16842.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040014"
15
Brad Bishopd5ae7d92018-06-14 09:52:03 -070016SRC_URI[md5sum] = "31d0a9f48dc796a7db351898a1e5058a"
17SRC_URI[sha256sum] = "5f6f336921cf5b84de56afbd08dfb70adeef2303751ffb3e570c936c6d656c9c"
Brad Bishop316dfdd2018-06-25 12:45:53 -040018
Brad Bishop6f8dcde2018-10-16 10:47:12 +080019CVE_PRODUCT = "curl libcurl"
Brad Bishop316dfdd2018-06-25 12:45:53 -040020inherit autotools pkgconfig binconfig multilib_header
21
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} gnutls libidn proxy threaded-resolver verbose zlib"
23PACKAGECONFIG_class-native = "ipv6 proxy ssl threaded-resolver verbose zlib"
24PACKAGECONFIG_class-nativesdk = "ipv6 proxy ssl threaded-resolver verbose zlib"
Brad Bishop316dfdd2018-06-25 12:45:53 -040025
26# 'ares' and 'threaded-resolver' are mutually exclusive
27PACKAGECONFIG[ares] = "--enable-ares,--disable-ares,c-ares"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028PACKAGECONFIG[brotli] = "--with-brotli,--without-brotli,brotli"
29PACKAGECONFIG[builtinmanual] = "--enable-manual,--disable-manual"
Brad Bishop316dfdd2018-06-25 12:45:53 -040030PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
31PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
32PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
33PACKAGECONFIG[imap] = "--enable-imap,--disable-imap,"
34PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
35PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
36PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,"
37PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
38PACKAGECONFIG[libidn] = "--with-libidn2,--without-libidn2,libidn2"
39PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080040PACKAGECONFIG[mbedtls] = "--with-mbedtls=${STAGING_DIR_TARGET},--without-mbedtls,mbedtls"
Brad Bishop316dfdd2018-06-25 12:45:53 -040041PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2"
42PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
43PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"
44PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
45PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp,"
46PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
47PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp,"
48PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
49PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet,"
50PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
51PACKAGECONFIG[threaded-resolver] = "--enable-threaded-resolver,--disable-threaded-resolver"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080052PACKAGECONFIG[verbose] = "--enable-verbose,--disable-verbose"
Brad Bishop316dfdd2018-06-25 12:45:53 -040053PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
54
55EXTRA_OECONF = " \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080056 --disable-libcurl-option \
57 --disable-ntlm-wb \
Brad Bishop316dfdd2018-06-25 12:45:53 -040058 --enable-crypto-auth \
59 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
60 --without-libmetalink \
61 --without-libpsl \
62"
63
64do_install_append_class-target() {
65 # cleanup buildpaths from curl-config
66 sed -i \
67 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
68 -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \
69 -e 's|${DEBUG_PREFIX_MAP}||g' \
70 ${D}${bindir}/curl-config
71}
72
73PACKAGES =+ "lib${BPN}"
74
75FILES_lib${BPN} = "${libdir}/lib*.so.*"
76RRECOMMENDS_lib${BPN} += "ca-certificates"
77
78FILES_${PN} += "${datadir}/zsh"
79
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080080inherit multilib_script
81MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/curl-config"
82
Brad Bishop316dfdd2018-06-25 12:45:53 -040083BBCLASSEXTEND = "native nativesdk"