blob: 9a712706839530b22a3e108f411b368f937d912a [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Convert text file line endings between CRLF and LF"
2DESCRIPTION = "The Dos2unix package includes utilities dos2unix and \
3unix2dos to convert plain text files in DOS or Mac format to Unix \
4format and vice versa."
5HOMEPAGE = "http://waterlan.home.xs4all.nl/dos2unix.html"
6SECTION = "support"
7
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://COPYING.txt;md5=1b78fca784db24f4a40e30b300787f3f"
10
11SRC_URI = "git://git.code.sf.net/p/dos2unix/dos2unix"
12UPSTREAM_CHECK_GITTAGREGEX = "dos2unix-(?P<pver>(\d+(\.\d+)+))"
13
14# Release 7.4.0
15SRCREV = "1182533bde3c1fe65be2ead465e87671faa2c027"
16
17S = "${WORKDIR}/git/dos2unix"
18
19inherit gettext perlnative
20
21# The dos2unix NLS relies on po4a-native, while po4a recipe is
22# provided by meta-perl layer, so make it optional here, you
23# need have meta-perl in bblayers.conf before enabling nls in
24# PACKAGECONFIG.
25PACKAGECONFIG ??= ""
26PACKAGECONFIG[nls] = "ENABLE_NLS=1,ENABLE_NLS=,po4a-native"
27
28EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS} LDFLAGS_USER='${LDFLAGS}'"
29EXTRA_OEMAKE_class-native = "ENABLE_NLS="
30
31do_install () {
32 oe_runmake DESTDIR="${D}${base_prefix}" install
33}
34
35BBCLASSEXTEND = "native nativesdk"