blob: c745dbbfe71edae1a0575cae015c302f40cd9a61 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001require gmp.inc
2
3LICENSE = "GPLv2+ | LGPLv3+"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
6 file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
7 file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8"
9
10REVISION = ""
11SRC_URI = "https://gmplib.org/download/${BPN}/${BP}${REVISION}.tar.bz2 \
12 file://amd64.patch \
13 file://use-includedir.patch \
14 file://0001-Append-the-user-provided-flags-to-the-auto-detected-.patch \
15 file://0001-confiure.ac-Believe-the-cflags-from-environment.patch \
16 "
17SRC_URI[md5sum] = "8ddbb26dc3bd4e2302984debba1406a5"
18SRC_URI[sha256sum] = "5275bb04f4863a13516b2f39392ac5e272f5e1bb8057b18aec1c9b79d73d8fb2"
19
20acpaths = ""
21
22EXTRA_OECONF += " --enable-cxx=detect"
23EXTRA_OECONF_mipsarchr6_append = " --disable-assembly"
24
25PACKAGES =+ "libgmpxx"
26FILES_libgmpxx = "${libdir}/libgmpxx${SOLIBS}"
27
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028do_install_append() {
29 oe_multilib_header gmp.h
30}
31
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032do_install_prepend_class-target() {
33 sed -i \
34 -e "s|--sysroot=${STAGING_DIR_HOST}||g" \
35 -e "s|${DEBUG_PREFIX_MAP}||g" \
36 ${B}/gmp.h
Brad Bishop6e60e8b2018-02-01 10:27:11 -050037}
38
39SSTATE_SCAN_FILES += "gmp.h"
40
41# Doesn't compile in MIPS16e mode due to use of hand-written
42# assembly
43MIPS_INSTRUCTION_SET = "mips"
44
45BBCLASSEXTEND = "native nativesdk"