blob: 0f91e05a6c9db7ecebab7730d598a152c7a9ffd1 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "An asynchronous event notification library"
2HOMEPAGE = "http://libevent.org/"
3BUGTRACKER = "https://github.com/libevent/libevent/issues"
4SECTION = "libs"
5
6LICENSE = "BSD & MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549"
8
9SRC_URI = " \
10 https://github.com/libevent/libevent/releases/download/release-${PV}-stable/${BP}-stable.tar.gz \
11 file://Makefile-missing-test-dir.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040012 file://0001-test-fix-32bit-linux-regress.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013 file://run-ptest \
14"
15
16SRC_URI[md5sum] = "f3eeaed018542963b7d2416ef1135ecc"
17SRC_URI[sha256sum] = "965cc5a8bb46ce4199a47e9b2c9e1cae3b137e8356ffdad6d94d3b9069b71dc2"
18
19UPSTREAM_CHECK_URI = "http://libevent.org/"
20
21S = "${WORKDIR}/${BPN}-${PV}-stable"
22
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
25
26inherit autotools
27
28# Needed for Debian packaging
29LEAD_SONAME = "libevent-2.1.so"
30
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031inherit ptest multilib_header
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032
33DEPENDS = "zlib"
34
35BBCLASSEXTEND = "native nativesdk"
36
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037do_install_append() {
38 oe_multilib_header event2/event-config.h
39}
40
Brad Bishopd7bf8c12018-02-25 22:55:05 -050041do_install_ptest() {
42 install -d ${D}${PTEST_PATH}/test
43 for file in ${B}/test/.libs/regress ${B}/test/.libs/test*
44 do
45 install -m 0755 $file ${D}${PTEST_PATH}/test
46 done
47}