blob: 0c6e116dd7b9be2d6cb57602dcf2cf0f2130a338 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Userspace library to access USB (version 1.0)"
2HOMEPAGE = "http://libusb.sf.net"
3BUGTRACKER = "http://www.libusb.org/report"
4SECTION = "libs"
5
6LICENSE = "LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
8
9BBCLASSEXTEND = "native nativesdk"
10
11SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-${PV}.tar.bz2 \
12 file://no-dll.patch \
13 file://run-ptest \
14 "
15
16SRC_URI[md5sum] = "466267889daead47674df933cea9cacb"
17SRC_URI[sha256sum] = "75aeb9d59a4fdb800d329a545c2e6799f732362193b465ea198f2aa275518157"
18
19S = "${WORKDIR}/libusb-${PV}"
20
21inherit autotools pkgconfig ptest
22
23# Don't configure udev by default since it will cause a circular
24# dependecy with udev package, which depends on libusb
25EXTRA_OECONF = "--libdir=${base_libdir} --disable-udev"
26
27do_install_append() {
28 install -d ${D}${libdir}
29 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
30 mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
31 fi
32}
33
34do_compile_ptest() {
35 oe_runmake -C tests stress
36}
37
38do_install_ptest() {
39 install -m 755 ${B}/tests/.libs/stress ${D}${PTEST_PATH}
40}
41
42FILES_${PN} += "${base_libdir}/*.so.*"
43
44FILES_${PN}-dev += "${base_libdir}/*.so ${base_libdir}/*.la"