blob: 48f50d8274af69627329aa4ddbb7c91989f2d682 [file] [log] [blame]
Andrew Geissler7f40b712020-05-15 14:09:53 -05001SUMMARY = "Berkeley TestFloat 3e"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05002DESCRIPTION = "Berkeley TestFloat is a small collection of programs for \
3 testing that an implementation of binary floating-point conforms to the \
4 IEEE Standard for Floating-Point Arithmetic."
5
6HOMEPAGE = "http://www.jhauser.us/arithmetic/TestFloat.html"
7
Brad Bishop2d39a062019-10-28 08:33:36 -04008LICENSE = "BSD-3-Clause"
Andrew Geissler7f40b712020-05-15 14:09:53 -05009LIC_FILES_CHKSUM = "file://TestFloat-${PV}/COPYING.txt;md5=d467c2d231054347e8fd885ac06e7b2b"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050010
11SRC_URI = "\
Andrew Geissler7f40b712020-05-15 14:09:53 -050012 http://www.jhauser.us/arithmetic/TestFloat-3e.zip;name=TestFloat \
13 http://www.jhauser.us/arithmetic/SoftFloat-3e.zip;name=SoftFloat \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050014 file://0001-Makefile-for-cross-compile-SoftFloat.patch \
15 file://0002-Makefile-for-cross-compile-TestFloat.patch \
16"
Andrew Geissler7f40b712020-05-15 14:09:53 -050017SRC_URI[TestFloat.md5sum] = "e70a1e6c6732abf79645a6dcca69a654"
18SRC_URI[TestFloat.sha256sum] = "6d4bdf0096b48a653aa59fc203a9e5fe18b5a58d7a1b715107c7146776a0aad6"
19SRC_URI[SoftFloat.md5sum] = "7dac954ea4aed0697cbfee800ba4f492"
20SRC_URI[SoftFloat.sha256sum] = "21130ce885d35c1fe73fc1e1bf2244178167e05c6747cad5f450cc991714c746"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050021
22S = "${WORKDIR}"
23
24do_compile(){
25 oe_runmake -C SoftFloat-${PV}/build/Linux-Cross-Compile/
26 oe_runmake -C TestFloat-${PV}/build/Linux-Cross-Compile/
27}
28
29do_install(){
30 install -d ${D}/${bindir}
31 install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/testfloat ${D}/${bindir}
32 install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/testfloat_gen ${D}/${bindir}
33 install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/testfloat_ver ${D}/${bindir}
34 install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/testsoftfloat ${D}/${bindir}
35 install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/timesoftfloat ${D}/${bindir}
36}