Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Xlib: C Language X Interface library" |
| 2 | |
| 3 | DESCRIPTION = "This package provides a client interface to the X Window \ |
| 4 | System, otherwise known as 'Xlib'. It provides a complete API for the \ |
| 5 | basic functions of the window system." |
| 6 | |
| 7 | require xorg-lib-common.inc |
| 8 | |
| 9 | FILESEXTRAPATHS =. "${FILE_DIRNAME}/libx11:" |
| 10 | |
| 11 | PE = "1" |
| 12 | |
| 13 | # temporarily override SRC_URI which is hard-coded in xorg-lib-common.inc |
| 14 | # since new versions of packages use a new compression format - .tar.gz |
| 15 | SRC_URI = "${XORG_MIRROR}/individual/lib/${XORG_PN}-${PV}.tar.xz" |
| 16 | |
| 17 | SRC_URI += "file://disable_tests.patch \ |
| 18 | " |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 19 | SRC_URI[sha256sum] = "1bc41aa1bbe01401f330d76dfa19f386b79c51881c7bbfee9eb4e27f22f2d9f7" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 20 | |
| 21 | PROVIDES = "virtual/libx11" |
| 22 | |
| 23 | XORG_PN = "libX11" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 24 | LICENSE = "MIT & MIT & BSD-1-Clause & HPND & HPND-sell-variant" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 25 | LIC_FILES_CHKSUM = "file://COPYING;md5=172255dee66bb0151435b2d5d709fcf7" |
| 26 | |
| 27 | DEPENDS += "xorgproto \ |
| 28 | xtrans \ |
| 29 | libxcb \ |
| 30 | xorgproto-native \ |
| 31 | autoconf-archive \ |
| 32 | " |
| 33 | |
| 34 | EXTRA_OECONF += "--with-keysymdefdir=${STAGING_INCDIR}/X11/ --disable-xf86bigfont" |
| 35 | EXTRA_OEMAKE += 'CWARNFLAGS=""' |
| 36 | |
| 37 | PACKAGECONFIG ??= "xcms" |
| 38 | PACKAGECONFIG[xcms] = "--enable-xcms,--disable-xcms" |
| 39 | |
| 40 | PACKAGES =+ "${PN}-xcb" |
| 41 | |
| 42 | inherit gettext |
| 43 | |
| 44 | FILES:${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB ${datadir}/X11/Xcms.txt" |
| 45 | FILES:${PN}-xcb += "${libdir}/libX11-xcb.so.*" |
| 46 | FILES:${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale" |
| 47 | |
| 48 | BBCLASSEXTEND = "native nativesdk" |