Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Python bindings for GStreamer 1.0" |
| 2 | DESCRIPTION = "GStreamer Python binding overrides (complementing the bindings \ |
| 3 | provided by python-gi) " |
| 4 | HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/" |
| 5 | SECTION = "multimedia" |
| 6 | |
| 7 | LICENSE = "LGPL-2.1-or-later" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740" |
| 9 | |
| 10 | SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz" |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "db348120eae955b8cc4de3560a7ea06e36d6e1ddbaa99a7ad96b59846601cfdc" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 12 | |
| 13 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject" |
| 14 | RDEPENDS:${PN} += "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject" |
| 15 | |
| 16 | PNREAL = "gst-python" |
| 17 | |
| 18 | S = "${WORKDIR}/${PNREAL}-${PV}" |
| 19 | |
| 20 | EXTRA_OEMESON += "\ |
| 21 | -Dtests=disabled \ |
| 22 | -Dplugin=enabled \ |
| 23 | -Dlibpython-dir=${libdir} \ |
| 24 | " |
| 25 | |
| 26 | # gobject-introspection is mandatory and cannot be configured |
| 27 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 28 | GIR_MESON_OPTION = "" |
| 29 | |
| 30 | inherit meson pkgconfig setuptools3-base upstream-version-is-even gobject-introspection features_check |