blob: 73ac563dc9d100bfc4189f4835a6c47163f937ad [file] [log] [blame]
Patrick Williamsa369e9f2016-06-22 16:30:42 -05001SUMMARY = "Python GObject bindings"
2SECTION = "devel/python"
3LICENSE = "LGPLv2.1"
4
5RECIPE_NO_UPDATE_REASON = "Newer versions of python-pygobject depend on gobject-introspection which doesn't cross-compile"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
8DEPENDS = "python python-pygobject-native libffi glib-2.0"
9DEPENDS_class-native = "python-native libffi-native glib-2.0-native"
10RDEPENDS_class-native = ""
11
12MAJ_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
13
Brad Bishopde7dfbc2018-02-23 14:35:39 -050014SRC_URI = "${GNOME_MIRROR}/pygobject/${MAJ_VER}/pygobject-${PV}.tar.xz \
Patrick Williamsa369e9f2016-06-22 16:30:42 -050015 file://obsolete_automake_macros.patch \
16"
17
18# libtool-native doesn't have fixinstall.patch applied which means
Andrew Geissler1b933da2020-04-14 09:00:47 -050019# that libs get relinked at installation time. This triggers a
Patrick Williamsa369e9f2016-06-22 16:30:42 -050020# relinking along the lines of:
21# gcc -L/tmp/foo/media/build1/poky/build/tmp/sysroots/x86_64-linux/usr/lib -lpyglib-2.0-python -o .libs/_glib.so
22# where /tmp/foo is DESTDIR and pyglib-2.0-python may be installed/reinstalled
23# at the same time as the gcc command runs.
24# If this happens between the handoff between gcc and ld, you can see:
25# /bin/ld: cannot find -lpyglib-2.0-python
26# Adding a dependency rule like install-pyglibLTLIBRARIES: install-libLTLIBRARIES
Andrew Geissler1b933da2020-04-14 09:00:47 -050027# would be ideal but automake can't cope with that without manually
Patrick Williamsa369e9f2016-06-22 16:30:42 -050028# defining the whole function. Give up and disable parallel make in native builds.
29PARALLEL_MAKEINST_class-native = ""
30
Brad Bishopde7dfbc2018-02-23 14:35:39 -050031SRC_URI[md5sum] = "ae48b60c690c4aa894e69e0c97802745"
32SRC_URI[sha256sum] = "bb9d25a3442ca7511385a7c01b057492095c263784ef31231ffe589d83a96a5a"
Patrick Williamsa369e9f2016-06-22 16:30:42 -050033S = "${WORKDIR}/pygobject-${PV}"
34
35EXTRA_OECONF += "--disable-introspection"
36
37inherit autotools distutils-base pkgconfig
38
39# necessary to let the call for python-config succeed
40export BUILD_SYS
41export HOST_SYS
42export STAGING_INCDIR
43export STAGING_LIBDIR
44
45PACKAGES += "${PN}-lib"
46
47RDEPENDS_${PN} += "python-textutils"
48
49FILES_${PN} = "${libdir}/python*"
50FILES_${PN}-lib = "${libdir}/lib*.so.*"
51FILES_${PN}-dev += "${bindir} ${datadir}"
52
53BBCLASSEXTEND = "native"