Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Support for reading various archive formats" |
| 2 | DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats" |
| 3 | HOMEPAGE = "http://www.libarchive.org/" |
| 4 | SECTION = "devel" |
| 5 | LICENSE = "BSD" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=ed99aca006bc346974bb745a35336425" |
| 7 | |
| 8 | DEPENDS = "e2fsprogs-native" |
| 9 | |
| 10 | PACKAGECONFIG ?= "zlib bz2 xz lzo" |
| 11 | |
| 12 | PACKAGECONFIG_append_class-target = "\ |
| 13 | libxml2 \ |
| 14 | ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)} \ |
| 15 | " |
| 16 | |
| 17 | DEPENDS_BZIP2 = "bzip2-replacement-native" |
| 18 | DEPENDS_BZIP2_class-target = "bzip2" |
| 19 | |
| 20 | PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl," |
| 21 | PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr," |
| 22 | PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib," |
| 23 | PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,${DEPENDS_BZIP2}," |
| 24 | PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz," |
| 25 | PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl," |
| 26 | PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2," |
| 27 | PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat," |
| 28 | PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo," |
| 29 | PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle," |
| 30 | PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4," |
| 31 | |
| 32 | EXTRA_OECONF += "--enable-largefile" |
| 33 | |
| 34 | SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz \ |
| 35 | file://non-recursive-extract-and-list.patch \ |
| 36 | file://bug1066.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 37 | file://CVE-2018-1000877.patch \ |
| 38 | file://CVE-2018-1000878.patch \ |
| 39 | file://CVE-2018-1000879.patch \ |
| 40 | file://CVE-2018-1000880.patch \ |
| 41 | file://CVE-2019-1000019.patch \ |
| 42 | file://CVE-2019-1000020.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 43 | " |
| 44 | |
| 45 | SRC_URI[md5sum] = "4038e366ca5b659dae3efcc744e72120" |
| 46 | SRC_URI[sha256sum] = "ba7eb1781c9fbbae178c4c6bad1c6eb08edab9a1496c64833d1715d022b30e2e" |
| 47 | |
| 48 | inherit autotools update-alternatives pkgconfig |
| 49 | |
| 50 | CPPFLAGS += "-I${WORKDIR}/extra-includes" |
| 51 | |
| 52 | do_configure[cleandirs] += "${WORKDIR}/extra-includes" |
| 53 | do_configure_prepend() { |
| 54 | # We just need the headers for some type constants, so no need to |
| 55 | # build all of e2fsprogs for the target |
| 56 | cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/ |
| 57 | } |
| 58 | |
| 59 | ALTERNATIVE_PRIORITY = "80" |
| 60 | |
| 61 | PACKAGES =+ "bsdtar" |
| 62 | FILES_bsdtar = "${bindir}/bsdtar" |
| 63 | |
| 64 | ALTERNATIVE_bsdtar = "tar" |
| 65 | ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar" |
| 66 | ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar" |
| 67 | |
| 68 | PACKAGES =+ "bsdcpio" |
| 69 | FILES_bsdcpio = "${bindir}/bsdcpio" |
| 70 | |
| 71 | ALTERNATIVE_bsdcpio = "cpio" |
| 72 | ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio" |
| 73 | ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio" |
| 74 | |
| 75 | BBCLASSEXTEND = "native nativesdk" |