blob: 6989358f964de7bb69c9089b47d134d28c34179d [file] [log] [blame]
Tom Josephcf7e8492017-05-08 11:49:10 +05301SUMMARY = "Inventory to Sensor config for phosphor-host-ipmi"
2PR = "r1"
Brad Bishop75f03872018-11-03 09:41:57 -07003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Tom Josephcf7e8492017-05-08 11:49:10 +05305
6inherit native
Tom Josephcf7e8492017-05-08 11:49:10 +05307inherit phosphor-ipmi-host
Matt Spinler0a8ea632017-12-14 13:31:55 -06008inherit mrw-xml
Tom Josephcf7e8492017-05-08 11:49:10 +05309
10SRC_URI += "file://config.yaml"
11
12DEPENDS += " \
13 mrw-native \
14 mrw-perl-tools-native \
15 "
16
17PROVIDES += "virtual/phosphor-ipmi-inventory-sel"
18
19S = "${WORKDIR}"
20
21do_install() {
22 DEST=${D}${sensor_datadir}
23 install -d ${DEST}
24
25 ${bindir}/perl-native/perl \
26 ${bindir}/gen_ipmi_sel.pl \
Matt Spinler0a8ea632017-12-14 13:31:55 -060027 -i ${mrw_datadir}/${MRW_XML} \
Tom Josephcf7e8492017-05-08 11:49:10 +053028 -m config.yaml \
29 -o ${DEST}/invsensor.yaml
30}