Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "This module contains functions for converting between Julian dates and calendar dates" |
| 2 | DESCRIPTION = "A function for converting Gregorian calendar dates to Julian dates, \ |
| 3 | and another function for converting Julian calendar dates to Julian dates are defined. \ |
| 4 | Two functions for the reverse calculations are also defined." |
| 5 | |
| 6 | HOMEPAGE = "https://github.com/phn/jdcal" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 7 | LICENSE = "BSD-2-Clause" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bd236e1f590973467a427bb354be0f46" |
| 9 | |
| 10 | inherit pypi setuptools3 ptest |
| 11 | |
| 12 | SRC_URI[md5sum] = "e05bdb60fa80f25bc60e73e0c6b7c5dc" |
| 13 | SRC_URI[sha256sum] = "472872e096eb8df219c23f2689fc336668bdb43d194094b5cc1707e1640acfc8" |
| 14 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 15 | RDEPENDS:${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | |
| 17 | SRC_URI += " \ |
| 18 | file://run-ptest \ |
| 19 | " |
| 20 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | RDEPENDS:${PN}-ptest += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | ${PYTHON_PN}-pytest \ |
| 23 | " |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | cp -f ${S}/test_jdcal.py ${D}${PTEST_PATH}/ |
| 27 | } |