blob: 401331be39326704e46254798c134206b6ceaa8b [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
Brad Bishop1d80a2e2019-11-15 16:35:03 -050014SRC_URI[md5sum] = "63d1c835b861912ea0dfd52cf66a2da4"
15SRC_URI[sha256sum] = "cd2d8ea360431a2ea35ff61c276bcf2afee1ad901668a0b50ae9f1c5814756bd"
Brad Bishopc342db32019-05-15 21:57:59 -040016
Brad Bishopf3f93bb2019-10-16 14:33:32 -040017UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
18
Brad Bishop15ae2502019-06-18 21:44:24 -040019inherit autotools ptest bash-completion
20
Brad Bishopc342db32019-05-15 21:57:59 -040021RDEPENDS_${PN}-ptest += "make"
22
23do_compile_ptest() {
24 oe_runmake buildtest-TESTS
25}
26
27do_install_ptest () {
28 cp ${B}/Makefile ${D}${PTEST_PATH}
29 install ${B}/test-cmdline ${D}${PTEST_PATH}
30 install ${B}/test-features ${D}${PTEST_PATH}
31 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
32 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
33}