blob: 2b5a8f94540894a41a25fdda301eee4a98a7108f [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11 file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
13DEPENDS = "expat libxml2 libffi wayland-native"
14
15SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
16 file://fixpathinpcfiles.patch \
Brad Bishop1d80a2e2019-11-15 16:35:03 -050017 file://0001-scanner-Add-configure-check-for-strndup.patch \
18 file://0002-Move-wl_priv_signal-to-wayland-server-private.h.patch \
Brad Bishop19323692019-04-05 15:28:33 -040019 "
20SRC_URI[md5sum] = "d91f970aea11fd549eae023d06f91af3"
21SRC_URI[sha256sum] = "72aa11b8ac6e22f4777302c9251e8fec7655dc22f9d94ee676c6b276f95f91a4"
22
23UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
24
25inherit autotools pkgconfig
26
27EXTRA_OECONF = "--disable-documentation --with-host-scanner"
28EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
29
30# Wayland installs a M4 macro for other projects to use, which uses the target
31# pkg-config to find files. Replace pkg-config with pkg-config-native.
32do_install_append_class-native() {
33 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
34 -e 's,$PKG_CONFIG,pkg-config-native,g' \
35 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
36}
37
38sysroot_stage_all_append_class-target () {
39 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
40 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
41}
42
43FILES_${PN} = "${libdir}/*${SOLIBS}"
44FILES_${PN}-dev += "${bindir} ${datadir}/wayland"
45
46BBCLASSEXTEND = "native nativesdk"