blob: 233e0dc4a4d785b77d8b136eaef274e464fd34c0 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "New GNU Portable Threads library"
2HOMEPAGE = "http://www.gnupg.org/software/pth/"
3SECTION = "libs"
4LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "\
6 file://COPYING.LIB;md5=2caced0b25dfefd4c601d92bd15116de\
7 "
8UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
9SRC_URI = "${GNUPG_MIRROR}/npth/npth-${PV}.tar.bz2 \
10 file://pkgconfig.patch \
11 "
12
13SRC_URI[md5sum] = "375d1a15ad969f32d25f1a7630929854"
14SRC_URI[sha256sum] = "1393abd9adcf0762d34798dc34fdcf4d0d22a8410721e76f1e3afcd1daa4e2d1"
15
16BINCONFIG = "${bindir}/npth-config"
17
18inherit autotools binconfig-disabled multilib_header
19
20FILES_${PN} = "${libdir}/libnpth.so.*"
21FILES_${PN}-dev += "${bindir}/npth-config"
22
23do_install_append() {
24 oe_multilib_header npth.h
25}
26
Brad Bishop1d80a2e2019-11-15 16:35:03 -050027BBCLASSEXTEND = "native nativesdk"