blob: d16cea3135826dfea5d2a7a829e8298cdc73efe9 [file] [log] [blame]
Eddie Jamesb2b7ff62018-02-09 11:59:18 -06001SUMMARY = "Insecure private key for testing and development"
2DESCRIPTION = "Do not use this key to sign images."
3PR = "r1"
Brad Bishop75f03872018-11-03 09:41:57 -07004LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Eddie Jamesb2b7ff62018-02-09 11:59:18 -06006
7inherit allarch
8inherit native
Eddie Jamesb2b7ff62018-02-09 11:59:18 -06009
10SRC_URI += "file://OpenBMC.priv"
11
12do_install() {
13 bbplain "Using an insecure image signing key!"
14 install -d ${D}${datadir}
15 install -m 400 ${WORKDIR}/OpenBMC.priv ${D}${datadir}
16}