blob: af21b60563e40c2052bb4cbece3fa84e8f8f042c [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Utilities for managing LZMA compressed files"
Andrew Geissler82c905d2020-04-13 13:39:40 -05002HOMEPAGE = "https://tukaani.org/xz/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08003SECTION = "base"
4
5# The source includes bits of PD, GPLv2, GPLv3, LGPLv2.1+, but the only file
6# which is GPLv3 is an m4 macro which isn't shipped in any of our packages,
7# and the LGPL bits are under lib/, which appears to be used for libgnu, which
8# appears to be used for DOS builds. So we're left with GPLv2+ and PD.
9LICENSE = "GPLv2+ & GPL-3.0-with-autoconf-exception & LGPLv2.1+ & PD"
10LICENSE_${PN} = "GPLv2+"
11LICENSE_${PN}-dev = "GPLv2+"
12LICENSE_${PN}-staticdev = "GPLv2+"
13LICENSE_${PN}-doc = "GPLv2+"
14LICENSE_${PN}-dbg = "GPLv2+"
15LICENSE_${PN}-locale = "GPLv2+"
16LICENSE_liblzma = "PD"
17
18LIC_FILES_CHKSUM = "file://COPYING;md5=97d554a32881fee0aa283d96e47cb24a \
19 file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
20 file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
21 file://COPYING.LGPLv2.1;md5=4fbd65380cdd255951079008b364516c \
22 file://lib/getopt.c;endline=23;md5=2069b0ee710572c03bb3114e4532cd84 \
23 "
24
Andrew Geissler82c905d2020-04-13 13:39:40 -050025SRC_URI = "https://tukaani.org/xz/xz-${PV}.tar.gz"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050026SRC_URI[md5sum] = "0d270c997aff29708c74d53f599ef717"
27SRC_URI[sha256sum] = "f6f4910fd033078738bd82bfba4f49219d03b17eb0794eb91efbae419f4aba10"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028UPSTREAM_CHECK_REGEX = "xz-(?P<pver>\d+(\.\d+)+)\.tar"
29
Andrew Geissler82c905d2020-04-13 13:39:40 -050030CACHED_CONFIGUREVARS += "gl_cv_posix_shell=/bin/sh"
31
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080032inherit autotools gettext
33
34PACKAGES =+ "liblzma"
35
36FILES_liblzma = "${libdir}/liblzma*${SOLIBS}"
37
38inherit update-alternatives
39ALTERNATIVE_PRIORITY = "100"
40ALTERNATIVE_${PN} = "xz xzcat unxz \
41 lzma lzcat unlzma"
42
43BBCLASSEXTEND = "native nativesdk"