blob: 769a1348d8fc98015c81ca6564fcd0d340c589ab [file] [log] [blame]
Michael Tritz330f9962017-04-12 16:08:39 -05001SUMMARY = "POWER9 CFAM override"
2DESCRIPTION = "Applies user CFAM register overrides from file"
3PR = "r1"
Brad Bishop2879d322018-11-07 14:45:23 -05004LICENSE = "Apache-2.0"
Brad Bishop1ebdb612019-09-13 12:18:25 -04005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Michael Tritz330f9962017-04-12 16:08:39 -05006
7inherit obmc-phosphor-systemd
Michael Tritz330f9962017-04-12 16:08:39 -05008
9FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
10RDEPENDS_${PN} += "op-proc-control"
11
12S = "${WORKDIR}"
13
14TMPL = "cfam_override@.service"
15INSTFMT = "cfam_override@{0}.service"
Josh D. Kingb9ee5362017-04-06 14:43:46 -050016TGTFMT = "obmc-chassis-poweron@{0}.target"
Michael Tritz330f9962017-04-12 16:08:39 -050017FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
18
19SYSTEMD_SERVICE_${PN} += "${TMPL}"
20SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"