blob: 3c9c8eae2cbb273b2ae39a1ed90abbfa072df4a1 [file] [log] [blame]
Deepak Kodihalliba5ce782017-02-05 10:10:44 -06001SUMMARY = "Inventory config for openpower-vpd-parser"
2PR = "r1"
Brad Bishop2879d322018-11-07 14:45:23 -05003LICENSE = "Apache-2.0"
Brad Bishop1ebdb612019-09-13 12:18:25 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Deepak Kodihalliba5ce782017-02-05 10:10:44 -06005
6inherit native
Deepak Kodihalliba5ce782017-02-05 10:10:44 -06007inherit openpower-fru-vpd
8
9SRC_URI += "file://inventory"
10
11PROVIDES += "virtual/openpower-fru-inventory"
12
13S = "${WORKDIR}"
14
15do_install() {
16 # This recipe is supposed to create a systemd environment file
17 # with values for FRU types and paths. This example recipe
18 # uses a pre-defined file ($PN/inventory).
19
20 DEST=${D}${inventory_datadir_native}
21 install -d ${DEST}
22 install inventory ${DEST}
23}