blob: 49816260a06aa5dfff191f815e0a25ec11c5489d [file] [log] [blame]
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -05001SUMMARY = "Generated callout information for phosphor-logging"
2PR = "r1"
3
4inherit native
5inherit obmc-phosphor-license
6inherit phosphor-logging
7
8DEPENDS += " \
9 mrw-native \
10 mrw-perl-tools-native \
11 "
12
13PROVIDES += "virtual/phosphor-logging-callouts"
14
15S = "${WORKDIR}"
16
17do_install() {
18 DEST=${D}${callouts_datadir}
19 install -d ${DEST}
20
21 ${bindir}/perl-native/perl \
22 ${bindir}/gen_callouts.pl \
23 -m ${datadir}/obmc-mrw/${MACHINE}.xml \
24 -o ${DEST}/callouts.yaml
25}