blob: 58cc921a503ddf26bae0d2852198feb9d8f2fe93 [file] [log] [blame]
Mike Garrettc088ff22021-08-27 16:59:09 -05001SUMMARY = "Enable Host Boot"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${HPEBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
5
6inherit obmc-phosphor-systemd
7
8HOST_BOOT_SERVICE = "host-boot-enable.service"
9SYSTEMD_SERVICE:${PN} += "${HOST_BOOT_SERVICE}"
10
11HOST_BOOT_FMT = "../${HOST_BOOT_SERVICE}:multi-user.target.wants/${HOST_BOOT_SERVICE}"
12SYSTEMD_LINK_${PN} += "${HOST_BOOT_FMT}"
13
14SRC_URI += "file://host-boot-enable.service"
15SRC_URI += "file://host-boot-enable.sh"
16
17do_install() {
18 install -d ${D}${bindir}
19 install -m 0755 ${WORKDIR}/host-boot-enable.sh ${D}${bindir}
20}