Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | DESCRIPTION = ""Compress::Raw::Bzip2" provides an interface to the in-memory \ |
| 2 | compression/uncompression functions from the bzip2 compression library." |
| 3 | |
| 4 | SECTION = "libs" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 5 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 6 | |
| 7 | MAINTAINER= "Poky <poky@yoctoproject.org>" |
| 8 | HOMEPAGE= "https://metacpan.org/release/Compress-Raw-Bzip2" |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \ |
| 11 | file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d" |
| 12 | |
| 13 | SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/Compress-Raw-Bzip2-2.096.tar.gz" |
| 14 | |
| 15 | SRC_URI[md5sum] = "4fdb7ea5071e4b774c52c37331386355" |
| 16 | SRC_URI[sha256sum] = "a564e7634eca7740c5487d01effe1461e9e51b8909e69b3d8f5be98997958cbe" |
| 17 | |
| 18 | DEPENDS += "bzip2" |
| 19 | |
| 20 | S = "${WORKDIR}/Compress-Raw-Bzip2-${PV}" |
| 21 | |
| 22 | inherit cpan |
| 23 | |
| 24 | export BUILD_BZIP2="0" |
| 25 | export BZIP2_INCLUDE="-I${STAGING_DIR_HOST}${includedir}" |
| 26 | |
| 27 | do_compile() { |
| 28 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 29 | cpan_do_compile |
| 30 | } |
| 31 | |
| 32 | BBCLASSEXTEND = "native" |