Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | DESCRIPTION = "A small image for testing meta-security packages" |
| 2 | |
Andrew Geissler | d1d22e6 | 2020-10-16 10:14:32 -0500 | [diff] [blame] | 3 | require security-build-image.bb |
| 4 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 5 | IMAGE_FEATURES += "ssh-server-openssh" |
| 6 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 7 | IMAGE_INSTALL:append = "\ |
| 8 | ${@bb.utils.contains("DISTRO_FEATURES", "smack", "smack-test", "",d)} \ |
| 9 | ${@bb.utils.contains("BBFILE_COLLECTIONS", "tpm-layer", "packagegroup-security-tpm","", d)} \ |
| 10 | ${@bb.utils.contains("BBFILE_COLLECTIONS", "tpm-layer", "packagegroup-security-tpm2","", d)} \ |
| 11 | ${@bb.utils.contains("BBFILE_COLLECTIONS", "parsec-layer", "packagegroup-security-parsec","", d)} \ |
| 12 | ${@bb.utils.contains("BBFILE_COLLECTIONS", "integrity", "packagegroup-ima-evm-utils","", d)} \ |
| 13 | " |
| 14 | |
| 15 | TEST_SUITES = "ssh ping apparmor clamav samhain sssd checksec smack suricata aide firejail" |
| 16 | TEST_SUITES:append = " parsec tpm2 swtpm ima" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 17 | |
| 18 | INSTALL_CLAMAV_CVD = "1" |
| 19 | |
Andrew Geissler | d1d22e6 | 2020-10-16 10:14:32 -0500 | [diff] [blame] | 20 | IMAGE_OVERHEAD_FACTOR = "1.0" |
| 21 | IMAGE_ROOTFS_EXTRA_SPACE = "1124288" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 22 | |
Andrew Geissler | d1d22e6 | 2020-10-16 10:14:32 -0500 | [diff] [blame] | 23 | # ptests need more memory than standard to avoid the OOM killer |
| 24 | # also lttng-tools needs /tmp that has at least 1G |
| 25 | QB_MEM = "-m 2048" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 26 | |
Andrew Geissler | d1d22e6 | 2020-10-16 10:14:32 -0500 | [diff] [blame] | 27 | PTEST_EXPECT_FAILURE = "1" |