blob: 97daab696e0ff269a8a466e19e332b8252b70d0d [file] [log] [blame]
mustafae67e2282021-03-29 15:08:45 -05001SUMMARY = "Initialize PWM sensors"
2DESCRIPTION = "Initialize PWM sensors"
3LICENSE = "CLOSED"
4PR = "r1"
5
6inherit systemd
7
8DEPENDS = "systemd"
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -05009RDEPENDS:${PN} = "bash"
mustafae67e2282021-03-29 15:08:45 -050010
11S = "${WORKDIR}"
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050012FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
mustafae67e2282021-03-29 15:08:45 -050013SRC_URI += " \
14 file://pwm_init.service \
15 file://bin/pwm_init.sh \
16 "
17
18SYSTEMD_PACKAGES = "${PN}"
19SYSTEMD_AUTO_ENABLE = "enable"
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050020SYSTEMD_SERVICE:${PN} += "pwm_init.service"
mustafae67e2282021-03-29 15:08:45 -050021
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050022FILES:${PN} += "${bindir}/* ${systemd_system_unitdir}/*"
mustafae67e2282021-03-29 15:08:45 -050023
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050024do_install:append() {
Charles Boyer2adad362021-11-24 15:58:03 -060025 install -d ${D}${libexecdir}/${PN}
26 install -m 0755 ${S}/bin/* ${D}${libexecdir}/${PN}/
mustafae67e2282021-03-29 15:08:45 -050027 install -d ${D}${systemd_system_unitdir}
28 install -m 0644 ${S}/*.service ${D}${systemd_system_unitdir}
29}