blob: e737f502ad6244549db18981475989ded6b01cf7 [file] [log] [blame]
Brad Bishopa48c0142020-01-06 09:48:41 -05001SUMMARY = "Daemon to ban hosts that cause multiple authentication errors."
2DESCRIPTION = "Fail2Ban scans log files like /var/log/auth.log and bans IP addresses having too \
3many failed login attempts. It does this by updating system firewall rules to reject new \
4connections from those IP addresses, for a configurable amount of time. Fail2Ban comes \
5out-of-the-box ready to read many standard log files, such as those for sshd and Apache, \
6and is easy to configure to read any log file you choose, for any error you choose."
7HOMEPAGE = "http://www.fail2ban.org"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
Brad Bishopa48c0142020-01-06 09:48:41 -05009LICENSE = "GPL-2.0"
10LIC_FILES_CHKSUM = "file://COPYING;md5=ecabc31e90311da843753ba772885d9f"
Brad Bishop15ae2502019-06-18 21:44:24 -040011
Andrew Geissler1fe918a2020-05-15 14:16:47 -050012SRCREV ="3befbb177017957869425c81a560edb8e27db75a"
13SRC_URI = " git://github.com/fail2ban/fail2ban.git;branch=0.11 \
14 file://initd \
Brad Bishopa48c0142020-01-06 09:48:41 -050015 file://fail2ban_setup.py \
16 file://run-ptest \
Andrew Geissler1fe918a2020-05-15 14:16:47 -050017 file://0001-python3-fail2ban-2-3-conversion.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040018"
Brad Bishopa48c0142020-01-06 09:48:41 -050019
20inherit update-rc.d ptest setuptools3
21
22S = "${WORKDIR}/git"
23
24do_compile_prepend () {
25 cp ${WORKDIR}/fail2ban_setup.py ${S}/setup.py
26}
27
28do_install_append () {
Andrew Geissler1fe918a2020-05-15 14:16:47 -050029 install -d ${D}/${sysconfdir}/fail2ban
30 install -d ${D}/${sysconfdir}/init.d
31 install -m 0755 ${WORKDIR}/initd ${D}${sysconfdir}/init.d/fail2ban-server
32 chown -R root:root ${D}/${bindir}
Brad Bishopa48c0142020-01-06 09:48:41 -050033}
34
35do_install_ptest_append () {
Andrew Geissler1fe918a2020-05-15 14:16:47 -050036 install -d ${D}${PTEST_PATH}
37 sed -i -e 's/##PYTHON##/${PYTHON_PN}/g' ${D}${PTEST_PATH}/run-ptest
38 install -D ${S}/bin/fail2ban-testcases ${D}${PTEST_PATH}
Brad Bishopa48c0142020-01-06 09:48:41 -050039}
40
41FILES_${PN} += "/run"
42
43INITSCRIPT_PACKAGES = "${PN}"
44INITSCRIPT_NAME = "fail2ban-server"
45INITSCRIPT_PARAMS = "defaults 25"
46
47INSANE_SKIP_${PN}_append = "already-stripped"
48
Andrew Geissler1fe918a2020-05-15 14:16:47 -050049RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog} iptables sqlite3 python3-core python3-pyinotify"
50RDEPENDS_${PN} += " python3-logging python3-fcntl python3-json"
Brad Bishopa48c0142020-01-06 09:48:41 -050051RDEPENDS_${PN}-ptest = "python3-core python3-io python3-modules python3-fail2ban"