blob: 292b9fd884c2f71b6ac1f96c8fa9e401a535f02a [file] [log] [blame]
Brad Bishop5f9be072016-06-27 14:53:52 -04001SUMMARY = "OpenBMC org.openbmc.Led example implementation"
2DESCRIPTION = "A sample implementation for the org.openbmc.Led DBUS API. \
3The org.openbmc.Led provides APIs for controlling LEDs."
4PR = "r1"
5
6inherit skeleton-sdbus
Brad Bishop1d525fa2016-08-17 20:27:37 -04007inherit obmc-phosphor-dbus-service
Brad Bishop5f9be072016-06-27 14:53:52 -04008
9RDEPENDS_${PN} += "libsystemd"
10
11SKELETON_DIR = "ledctl"
Brad Bishop1d525fa2016-08-17 20:27:37 -040012DBUS_SERVICE_${PN} += "org.openbmc.control.led.service"
13SYSTEMD_SERVICE_${PN} += "obmc-led-start@.service obmc-led-stop@.service"