blob: b4f0e9d9a57e62a87f6c39aeb11b9421b2b0b3c1 [file] [log] [blame]
Vijay Khemkafa9f2ad2020-10-08 16:36:28 -07001SUMMARY = "Virtual Sensors"
2DESCRIPTION = "virtual sensors created from existing sensors and config data"
3HOMEPAGE = "https://github.com/openbmc/phosphor-virtual-sensor"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
7
8inherit meson pkgconfig
9inherit systemd
10
11DEPENDS += "sdbusplus"
12DEPENDS += "phosphor-dbus-interfaces"
13DEPENDS += "sdeventplus"
14DEPENDS += "phosphor-logging"
15DEPENDS += "nlohmann-json"
16DEPENDS += "exprtk"
17
18SRC_URI = "git://github.com/openbmc/phosphor-virtual-sensor.git;protocol=git"
Andrew Geissler21095b72021-07-06 19:01:10 +000019SRCREV = "67d8b9d265c2abf6d88fa2bd654e8a177cdeb6c9"
Vijay Khemkafa9f2ad2020-10-08 16:36:28 -070020S = "${WORKDIR}/git"
21
22SYSTEMD_SERVICE_${PN} = "phosphor-virtual-sensor.service"