blob: 25b412662abde438ad63282dae336ce0c0a53564 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
4LICENSE = "GPLv2 & GPLv2+ & BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://include/pub_tool_basics.h;beginline=6;endline=29;md5=d4de0407239381463cf01dd276d7c22e \
7 file://include/valgrind.h;beginline=1;endline=56;md5=ad3b317f3286b6b704575d9efe6ca5df \
8 file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56"
9
10X11DEPENDS = "virtual/libx11"
11DEPENDS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)} \
12 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \
13 "
14
15SRC_URI = "ftp://sourceware.org/pub/valgrind/valgrind-${PV}.tar.bz2 \
16 file://fixed-perl-path.patch \
17 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
18 file://run-ptest \
19 file://0002-remove-rpath.patch \
20 file://0004-Fix-out-of-tree-builds.patch \
21 file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
22 file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
23 file://use-appropriate-march-mcpu-mfpu-for-ARM-test-apps.patch \
24 file://avoid-neon-for-targets-which-don-t-support-it.patch \
25 file://valgrind-make-ld-XXX.so-strlen-intercept-optional.patch \
26 file://0001-makefiles-Drop-setting-mcpu-to-cortex-a8-on-arm-arch.patch \
27 file://0001-str_tester.c-Limit-rawmemchr-test-to-glibc.patch \
28 file://0001-sigqueue-Rename-_sifields-to-__si_fields-on-musl.patch \
29 file://0002-context-APIs-are-not-available-on-musl.patch \
30 file://0003-correct-include-directive-path-for-config.h.patch \
31 file://0004-pth_atfork1.c-Define-error-API-for-musl.patch \
32 file://0005-tc20_verifywrap.c-Fake-__GLIBC_PREREQ-with-musl.patch \
33 file://0006-pth_detached3.c-Dereference-pthread_t-before-adding-.patch \
34 file://0001-memcheck-tests-Use-ucontext_t-instead-of-struct-ucon.patch \
35 file://0001-memcheck-arm64-Define-__THROW-if-not-already-defined.patch \
36 file://0002-memcheck-x86-Define-__THROW-if-not-defined.patch \
37 file://0003-tests-seg_override-Replace-__modify_ldt-with-syscall.patch \
38 file://link-gz-tests.patch \
39 file://ppc-headers.patch \
40 "
41SRC_URI[md5sum] = "817dd08f1e8a66336b9ff206400a5369"
42SRC_URI[sha256sum] = "d76680ef03f00cd5e970bbdcd4e57fb1f6df7d2e2c071635ef2be74790190c3b"
43UPSTREAM_CHECK_REGEX = "valgrind-(?P<pver>\d+(\.\d+)+)\.tar"
44
45COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux'
46
47# valgrind supports armv7 and above
48COMPATIBLE_HOST_armv4 = 'null'
49COMPATIBLE_HOST_armv5 = 'null'
50COMPATIBLE_HOST_armv6 = 'null'
51
52# X32 isn't supported by valgrind at this time
53COMPATIBLE_HOST_linux-gnux32 = 'null'
54COMPATIBLE_HOST_linux-muslx32 = 'null'
55
56# Disable for some MIPS variants
57COMPATIBLE_HOST_mipsarchn32 = 'null'
58COMPATIBLE_HOST_mipsarchr6 = 'null'
59
60inherit autotools ptest
61
62EXTRA_OECONF = "--enable-tls --without-mpicc"
63EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS') != '32']}"
64
65# valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
66EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
67TARGET_CC_ARCH_remove_arm = "${@get_mcpu(d)}"
68
69EXTRA_OEMAKE = "-w"
70
71CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
72
73# valgrind likes to control its own optimisation flags. It generally defaults
74# to -O2 but uses -O0 for some specific test apps etc. Passing our own flags
75# (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it
76# which fixes build path issue in DWARF.
77SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}"
78
79def get_mcpu(d):
80 for arg in (d.getVar('TUNE_CCARGS') or '').split():
81 if arg.startswith('-mcpu='):
82 return arg
83 else:
84 continue
85 return ""
86
87do_configure_prepend () {
88 rm -rf ${S}/config.h
89}
90
91do_install_append () {
92 install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/
93}
94
95TUNE = "${@strip_mcpu(d)}"
96
97RDEPENDS_${PN} += "perl"
98
99# valgrind needs debug information for ld.so at runtime in order to
100# redirect functions like strlen.
101RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
102
103RDEPENDS_${PN}-ptest += " sed perl perl-module-file-glob"
104RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
105
106# One of the tests contains a bogus interpreter path on purpose.
107# Skip file dependency check
108SKIP_FILEDEPS_${PN}-ptest = '1'
109
110do_compile_ptest() {
111 oe_runmake check
112}
113
114do_install_ptest() {
115 chmod +x ${B}/tests/vg_regtest
116
117 # The test application binaries are not automatically installed.
118 # Grab them from the build directory.
119 #
120 # The regression tests require scripts and data files that are not
121 # copied to the build directory. They must be copied from the
122 # source directory.
123 saved_dir=$PWD
124 for parent_dir in ${S} ${B} ; do
125 cd $parent_dir
126
127 # exclude shell or the package won't install
128 rm -rf none/tests/shell* 2>/dev/null
129
130 subdirs="tests cachegrind/tests callgrind/tests drd/tests helgrind/tests massif/tests memcheck/tests none/tests"
131
132 # Get the vg test scripts, filters, and expected files
133 for dir in $subdirs ; do
134 find $dir | cpio -pvdu ${D}${PTEST_PATH}
135 done
136 cd $saved_dir
137 done
138
139 # clean out build artifacts before building the rpm
140 find ${D}${PTEST_PATH} \
141 \( -name "Makefile*" \
142 -o -name "*.o" \
143 -o -name "*.c" \
144 -o -name "*.S" \
145 -o -name "*.h" \) \
146 -exec rm {} \;
147
148 # needed by massif tests
149 cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print
150
151 # handle multilib
152 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
153}