blob: 5ff48568655f9089cd556a80612fd3f8e9141696 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "X11 Mouse Theme"
2HOMEPAGE = "http://xfce-look.org/content/show.php/OpenZone?content=111343"
3SECTION = "x11/wm"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a2f562fb8fb1e138b810d69521c4bcd7"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05006
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007inherit allarch gtk-icon-cache
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008
9SRC_URI = "http://xfce-look.org/CONTENT/content-files/111343-OpenZone-${PV}.tar.xz"
10SRC_URI[md5sum] = "4dae968cbd525072664ef7a4fc7c4154"
11SRC_URI[sha256sum] = "dc20f97a49e1ff1becf7853ef5f137ed30a4c27490540e755021d78d339efd92"
12
13S = "${WORKDIR}/OpenZone"
14
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015do_compile() {
16}
17
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018do_install() {
19 install -d ${D}${datadir}/icons
20 for theme in `find -name '*.tar.xz'`; do
21 tar -Jxf ${theme} -C ${D}${datadir}/icons
22 done
23}
24
25python populate_packages_prepend () {
26 icondir = bb.data.expand('${datadir}/icons', d)
27 do_split_packages(d, icondir, '^(.*)', '%s', 'Open Zone cursors %s', allow_dirs=True)
28}
29
Andrew Geissler82c905d2020-04-13 13:39:40 -050030FILES_${PN} += "${datadir}/icons"
31
Patrick Williamsb48b7b42016-08-17 15:04:38 -050032PACKAGES_DYNAMIC += "^openzone-.*"
33ALLOW_EMPTY_${PN} = "1"