blob: 9547736bddb16eb0cbcd4965a93ba085727e4d59 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "X11 Mouse Theme"
2HOMEPAGE = "http://xfce-look.org/content/show.php/OpenZone?content=111343"
3SECTION = "x11/wm"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a2f562fb8fb1e138b810d69521c4bcd7"
6DEPENDS = "icon-slicer-native xcursorgen-native"
7
8inherit allarch
9
10SRC_URI = "http://xfce-look.org/CONTENT/content-files/111343-OpenZone-${PV}.tar.xz"
11SRC_URI[md5sum] = "4dae968cbd525072664ef7a4fc7c4154"
12SRC_URI[sha256sum] = "dc20f97a49e1ff1becf7853ef5f137ed30a4c27490540e755021d78d339efd92"
13
14S = "${WORKDIR}/OpenZone"
15
16do_install() {
17 install -d ${D}${datadir}/icons
18 for theme in `find -name '*.tar.xz'`; do
19 tar -Jxf ${theme} -C ${D}${datadir}/icons
20 done
21}
22
23python populate_packages_prepend () {
24 icondir = bb.data.expand('${datadir}/icons', d)
25 do_split_packages(d, icondir, '^(.*)', '%s', 'Open Zone cursors %s', allow_dirs=True)
26}
27
28PACKAGES_DYNAMIC += "^openzone-.*"
29ALLOW_EMPTY_${PN} = "1"